
Pro/ENGINEER Wildfire 3.0 Tips 
W. Durfee 
 

Keyboard/mouse shortcuts 
CTRL+D Default view 
Middle-Button Spin 
SHIFT+Middle Pan 
CTRL+Middle Zoom (press, drag up-down) 
CTRL+Middle Turn (press, drag left-right) 
Scroll Wheel Zoom 
CTRL+G Regenerate 
CTRL+R Repaint 
CTRL+A Activate window 
--- Refit (no key, use toolbar icon) 

Parts 
To change background color: View > Display Settings > System Colors. Change Background and 
uncheck Blended Background. 
 
To extrude: R-click for short-cut options.  
 
To dimension: Dimension tool > L-click start > L-click end > C-click to place. 
 
To dimension a diameter: L-click outside > L-click center line > L-click outside > C-click to place.  
 
To assign a material and/or density: Edit > Setup > Mass Props > enter density (Aluminum = 
0.095 lb/in^3, Steel = 0.282 lb/in^3). Units are current units for part. An even better way: Edit > 
Setup > Material > Define. Then Material > Assign.  
 
To find weight and c.g. of a part: Analysis > Model Analysis > Model Mass Properties > Compute 
 
To add relations: Double-click on part to show dimensions. Tools > Relations. Note that 
dimensions changed to symbols. In the Relations dialog box, use the toggle button to toggle 
between dimension symbols and numbers. Add relation like this (line 1 is a comment) 
/* notch is 1/4 the width */ 
d3 = (d1)/4 
 
To add a feature to the top of a part: Pick feature tool > Select Front as sketch plane. In 
References window, create new Ref by picking top surface of part (rotate to select) and deleting 
default top reference plane.  
 
To add a  round (or fillet): Pick round (or fillet) tool > Pick edge(s) > Drag handles, center-click.  
 
To copy a feature: Edit > Feature Operations > Copy > Same Refs | Select | Dependent > Done > 
select feature (use of model tree to select) > Done > In GP VAR DIMS box select feature location 
dimensions to change > Done. Follow messages.    
 
To mirror a feature: Edit > Feature Operations > Copy > Mirror | Select | Dependent > Done > 
select feature (use model tree to select) > Done > select plane to mirror about. 
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To make a pattern: Select feature. R-click > Pattern. (Or select the feature then the Pattern tool at 
the right.) Follow prompts to enter increment value, and total number of instances.  
 
To set units: Edit > Setup > Units > select units > Set > read warning box 
 
To edit dimensions: Double click on part then on dimension. Or right click on feature in menu tree 
> Edit. Regenerate when done.  
 
To change dimensioning scheme or to re-sketch part:  Rght click on feature in menu tree > Edit 
definition. Takes you to dash board. Placement > Edit Sketch. In the Sketch dialog, select Sketch.  
 
Raised text: Create protrusion on desired surface. Text tool in sketcher toolbar > follow directions, 
for text line draw bottom to top.  
 
Hex object: New feature > protrusion. Add 2 centerlines that go through the origin, spacing lines 
by about 120 deg with one of them about 60 deg from vertical. Dimension one of the lines to be 
60 deg from the vertical reference and dimension between lines to be 120 deg. Create a 
Center/Point circle (do not dimension this circle). Select circle, then Edit > toggle construction.  
Draw hexagon while constraining to the construction circle, the reference lines and the 
centerlines. Dimension across one flat; the rest will follow.  
 
To change model name: File > Rename.  
 
To view order that model was created: Tools > Model Player. Click for/rev arrows to step through 
model creation.  
 
To make a spring, use a helical sweep: Create new part. Insert > Helical Sweep > Protrusion > 
Constant | Thru Axis | Right Handed > Done. Select Front datum for sketch plane and Top datum 
for top reference. Create a vertical center line that passes through the origin. Create a vertical line 
of height 20.0 located 5.0 to the right of the origin. Accept the sketch. Enter pitch value of 4.0. 
Sketch a circular cross-section (the cross-section of the spring) of diameter 1.5. Accept the 
sketch. Preview the feature.  
 
Blends: Create a new part. Insert > Model Datum > Plane. Reference to FRONT, offset by 100. 
Select Sketch Tool icon at the right and sketch on the FRONT plane. Sketch the first cross 
section (a square). Accept the sketch. Create a second cross section sketch on DTM1. Each 
section in the blend must have the same number of vertices. Create the blend. Insert > Blend > 
Protrusion > Parallel | Regular Sec | Sketch Sec > Done > Straight > Done. Follow the message 
prompts. Select the FRONT sketch plane. Flip arrow to point towards the DTM1 plane. In 
sketcher, use the Create an entity from and edge tool to pick up all four edges of the square. Note 
the order of the vertices which must be consistent in the next section. When done, select the 
arrow tool then right press > Toggle Section. Use the edge tool to pick up the next section. 
Accept the sketch. Enter the depth of the section. Select Preview from the Protrusion dialog box, 
then OK.  
 
To color a part: View > Color and Appearance. Follow directions in Appearance Editor.  
 
To apply fancy rendering: View > Display Setting > Model Display > Shade tab > Check Real-time 
rendering.  
 
To add fancy rendering button: R-click in top tool bar > Commands > View > Drag Realtime 
Rendering button to model display toolbar.  
 
To create a new stored view: Reorient View button > Saved Views > enter name for new view > 
Save.  
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To suppress display of tangent lines: View > Display Settings > Model Display > Edge Line, 
Tangent Edges = No Display.  
 
If printouts of lines for transparent parts are not showing:  1. View > Display Settings > Model 
Display> Uncheck the box for colors.  2. View > Display Settings > System Colors > Scheme = 
Black on White.  3. In the Printer dialog box, choose Properties, then set resolution to something 
higher than 600x600 dpi (if this is an option.) 
 
To spin wildly: Orient mode button > R-click in window > Velocity mode. Drag part with center 
mouse button.  
 
To create a high quality rendering of the part for use in PowerPoint presentations or reports 
(taken from a Pro/E FAQ): You can dramatically improve the way your models appear directly 
onscreen by using Photorender: View -> Model Setup -> Render Control. Click "Render Final 
Image" on the toolbar that pops up and see the difference! If you do a screen capture now it is 
going to look so much better. The default background color for rendered images is black. To 
change the background, click "Modify Render Settings" on the rendering toolbar, and then check 
the "Render Room" box. Close that dialog and click "Modify Room Settings" on the render 
toolbar. Click on one of the walls and set the color to white, do the same for the ceiling and floor. 
Now render the final image and you'll have a white background instead of black. You can of 
course do much more detailed renderings and output to a file, but just doing the basic steps 
above to render the image directly on your screen will make a world of difference in any 
screenshots you take, and the process takes all of about 15 second 
 
To create a co-axial hole. Select axis (Set pick filter to Datums). Select hole tool. With Ctrl held 
down, select drilling surface or datum.  
 
To create a notch in a cylinder. In the sketcher, lay down a construction line that is at the edge of 
the cylinder and snap to that construction line.  

Drawings 
To select view, dimension, note or other object: Left click, object will turn red. Once selected can 
move or can right press to reveal pop-up menu of options.  
 
Create drawing on C size, print to A size sheet.  
 
To insert 3-D view: Insert > Drawing View > General. Click on drawing to place. In Drawing View 
box: View Type > pick orientation, Scale > pick custom scale.  Display in No Hidden format.  
 
To change obscure drawing parameters, with nothing selected, right press > Properties. From the 
top right menu pick Drawing Options. Scroll down the long list.  
 
To change dimension font size, follow directions above under obscure drawing parameters. 
 
To place text: Insert > Note > No Leader | Enter | Horizontal | Standard | Default > Make Note. 
Pick point in title block, enter text for note. Hit CR twice to finish. Done/Return to close note 
window. Select and move note to center. Right press > Properties to edit or to change font size, 
type, alignment, etc.  
 
To place text in a title frame: Use insert Note.  
 
To change font size/style: Format > Text Style 
 
To move a view: Select view (turns red) > L-press and move. If views won’t move, click the 
padlock icon at the top 
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To change dimension to another view: Select (turns red), right press > Move Item to View > select 
new view. 
 
To insert a dimension: Insert > Dimension > New References. Create dimension. If doing 
baseline dimensioning: Insert Dimension > Common Reference. Select baseline, then L-click/C-
click to create dimensions from baseline. You must add dimensions when the Constraint Manager 
adds constraints that drive dimensions that don’t show up with Show All. Some designers chose 
not to use Show/Erase and instead create all dimensions from scratch. This is only recommended 
in special circumstances.) 
 
To create a reference dimension: Insert > Reference Dimension > New reference. Create 
dimension.  
 
To show the tolerance for selected dimension: Select dimension > R-press > Properties > Value 
and tolerance.  
 
To show tolerance for all dimensions: View > Display Settings > Model Display > General tab > 
check Dimension tolerances > Apply > OK  
 
To change anything about a dimension: Select dimension > R-press > Properties. 
 
To change number of decimals in a dimension: Format > Decimal Places > follow directions in 
message area.  
 
To change border frame: File > Page Setup. Select from drop-down menu under Format 
 
To print: Print to PDF and view with Adobe Reader before printing. File > Print > OK. In the Print 
dialog, select Adobe PDF, then OK.  View and print from Reader.  
 
If border not coming out or if print is offset: File > Print > Configure . On Model tab, change Scale. 
Or on Page tab, change Offset. Experiment with the settings, checking results on the PDF file 
before printing a hard copy.  
 
To insert table for BOM or change records: Table > Insert > Table. Follow instructions in message 
window. After table is created, double-click in cell to enter text.  
 
To change directions of arrows: Select dimension (turns red). R-press > Flip Arrows 
 
To change drawing scale: Double click on SCALE at bottom left. 
 
To embed a dimension in a note: “This dimension is &D# …” where # is the dimension number.  
 
For multi-sheet dwga: Insert > Sheet.  
 
To place more than one model on a drawing: File > Properties > Drawing Models > Add Model. 
Use Set Model to switch between the active model for view insertion.  
 
Do not worry about yellow extension lines overlaying object lines; Pro/E will fix at print time.  
 
If you want a different dimensioning scheme, go back to Part mode and redefine the feature.  
 
To compute lengths or surface area: Analysis > Measure > follow directions.  
If get license invalid error on startup, try enabling the wireless or internet connection.  
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To create raised text: Create a protrusion feature on desired surface. In Sketcher, select Text tool 
icon. Follow directions in message window. To place text L-click lower left then upper left of first 
character.  
 
To change view type on 3-D view. Double-click view, View Display > Display Style = No Hidden 
 
To print a drawing: On the top toolbar, click the Send to PDF button (not available on all 
systems).  
 
To show centerlines: View > Show and Erase > select axes > Show > Show All.  
 
 
 

Assemblies 
R-click gives assembly options.  
 
To move a partially constrained part: Component Placement > Move > Translate.  
 
To edit a part from assembly view: Right click on part in menu tree > Open. This opens part view 
for editing.  
 
To change constraints: Right click on part in menu tree > Edit Definition.  
 
To change mate offset parameter: Double click on part or right click on part in menu tree > Edit. 
Assembly parameter will appear in yellow, double click to edit.  
 
Exploded view: View > Explode > Explode View 
 
To move components in exploded view: View > Explode > Edit Position 

General 
Pro/E tutorials at http://www.ptc.com/community/proewf/newtools/tutorials.htm#proe1
 
To unhide the browser, click on the expand arrows between the menu tree and the part window.  
 
Map keys (custom key stroke operations): Tools > Mapkeys. New > [enter key sequence and 
name]. Record > [do key strokes and mouse clicks, no clicks in graphics window] > Stop > OK 
Save > Close. Tools > Options > Open config. Suggestions for map keys: sv = shaded view, wv = 
wire view, dat = datums on/off, fv = front view, dv = default view 
 
Want others to see your parts, including spinning and zooming? Have them download 
ProductView Express from www.ptc.com. This is a web browser plug-in that enables viewing of 
Pro/E parts in Internet Explorer (not Mozilla). To use, open a part from Explorer.  
 
Config file: For customizing Pro/E. Tools > Options. Deselect “Show only options” box to see all 
options. At top, change Sort from Alphabetical to By Category. After making changes, click the 
Save a copy button. To load config file, Tools > Options > Open a config file.  
 
To change default units. Open Options. Click Find button. For keyword enter pro_unit_length. 
After finding, select the option, Pull down the Set value and select desired units. Click the 
Add/Change button.  
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There are three versions of Pro/E: Commercial (what companies have), Educational (installed in 
ITLabs), Student (what students buy for their home computer.) File transfer: Commercial version 
files transfer to education version, but not vice-versa. Student version and education version are 
two-way compatible.  There is no transfer, either way, between the student and commercial 
versions.  
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